Chapter 8. Frequently asked questions

Q: How can I visualise data from a text file?
Q: How can I plot data from a table (worksheet)?
Q: How can I export a plot to an image format?
Q: Can I export transparent images?
Q: How can I export a text file?
Q: How can I choose a window using the project explorer?
Q: How can I choose the data range from a plot curve, when doing a curve fit?
Q: Can I fit a plot curve using my own function?
Q: How can I visualize a pixel line profile from an image?
Q: How can I make a graph that has one x-axis, but two y-axes with different orders of magnitude?

Q: How can I visualise data from a text file?

A: Go to the File menu and select the Import -> Import ASCII... command.

Q: How can I plot data from a table (worksheet)?

A: Click on the table header to choose the columns to plot and then right click. Chose the 'Plot' option from the pop-up menu and then the type of plot you want.

You can also use the plot assistant: press 'CTRL+ALT+W' keys to show it, or go to 'View' menu -> 'Plot wizard'.

Q: How can I export a plot to an image format?

A: Right click in the plot window and chose the 'Export' option.

Q: Can I export transparent images?

A: Yes, ".png" images have transparent background. See the Export Graph -> Current command.

Q: How can I export a text file?

A: Go to the File menu and select the Export ASCII dialog.

Q: How can I choose a window using the project explorer?

A: Double click on the window name will show the window maximized, even if it was hidden before.

Q: How can I choose the data range from a plot curve, when doing a curve fit?

A: Go to the Data menu and use the Select Data Range command. Click in the plot window and use the 'Up' and 'Down' arrows keys to select the curve to analyse. Keeping 'CTRL' button and 'Left' or 'Right' arrow keys simultaneousely pressed permit to move the selected cursor and consequently to modify the data range.

Q: Can I fit a plot curve using my own function?

A: Go to the Analysis menu and select the The Fit Wizard... command. Define the function (myFunction=...), enter the initial guesses for the parameters, choose the fitting range and the number of iterations and click 'OK'

Q: How can I visualize a pixel line profile from an image?

A: Right click on the image you want to analyse and select the option 'View pixel line profile' from the popup menu. A dialog window opens and allows you to select the number of pixels used for the analysis. Choose a value and click "OK". Then click on the image to select the start point and move your mouse to select an end point while keeping the left button pressed. When you release the left button a plot window appears, representing the pixel intensity versus pixel index.

Q: How can I make a graph that has one x-axis, but two y-axes with different orders of magnitude?

A: Select at least two columns that you want to display and use the Double-Y.