Chapter 3. Command Reference

Table of Contents
The File Menu
The Edit Menu
The View Menu
The Scripting Menu
The Graph Menu
The Plot Menu
The 3D Plot menu
The Data Menu
The Analysis Menu
The Table Menu
The Matrix Menu
The Format Menu
The Windows Menu
Customization of 3D plots

The active items appearing in a menu depends upon which project window is active. For example, if the active window is a table, then all the items related to table functions are enabled and the others are automatically disabled.

The File Menu

Many of the commands from the File Menu are also linked to corresponding icons in the File Toolbar. Clicking one of these icons will directly execute the linked command.

File-> New ->

New -> New Project (Ctrl-N)

Creates a new QtiPlot project file. If another project is already open and has been saved at least once, it will be closed before the new project is created. If another project is open but has never been saved, a dialog will be opened to ask if the current project should be saved.

New -> New Folder (F7)

Adds a new folder to the project. The new folder is added to the current folder.

New -> New Table (Ctrl-T)

Creates a new (empty) table and adds it to the project. The empty table will have 30 rows and 2 columns. The number of rows and columns can be changed with the Rows and Columns of the Table menu.

The properties of each column (numeric format, column width, etc) can be modified using the Column Options... command of the Table menu. See the table section for more details.

New -> New Excel

Creates a new (empty) Excel workbook as an OLE instance in QtiPlot workspace and adds it to the project. This function only works on Windows operating systems where Microsoft Excel is available. See the Excel section for more details.

New -> New Matrix (Ctrl-M)

Creates a new (empty) Matrix and adds it to the project. The empty matrix will have 32x32 cells. These dimensions can be changed using the Set Dimensions... command of the Matrix menu

See the matrix section for more details.

New -> New Note

Creates a new note window and adds it to the project. A note is a simple text window which can be used to add comments to the current project.

New -> New Graph (Ctrl-G)

Creates a new 2D plot, that is, a graph window with a single, empty layer, and adds it to the project. Current defaults are used to create the layer, which is just a framework into which you add curves with the Add/Remove Curves... command.

New -> New Function Plot -> New Function Plot... (Ctrl-F)

Opens a dialog which is used to create a 2D plot by specifying an analytical function. See the 2D plot section of the tutorial for a general overview of this function.

The function can be defined in Cartesian, parametric or polar coordinates, see the Add Function... command for more details.

New -> New Function Plot -> New Parametric Function Plot...

Opens the parametric coordinates tab of the add function dialog which is used to create a 2D plot by specifying two parametrical functions: X=f1(m) and Y=f2(m).

New -> New Function Plot -> New 3D Surface Plot... (Ctrl-Alt-Z)

Opens a dialog which is used to create a 3D plot by specifying an analytical function. Only Cartesian coordinates are available. See the 3D plot section of the tutorial for more detail on this function.

New -> New Function Plot -> New 3D Parametric Surface Plot...

Opens the parametric coordinates tab of the surface dialog which is used to create a 3D plot by specifying the (X,Y,Z) data points as functions of the latitude and longitude variables u and v. Only Cartesian coordinates are available.

File -> Open (Ctrl-O)

Opens an existing QtiPlot project file (.qti). If your project has been saved in a compressed format, you must select the .qti.gz file format.

This command can also be used to open projects which have been built with Origin software.

File -> Open Excel

Opens a file dialog permitting you to select an Excel file. When a file is selected and opened, QtiPlot creates a new table for each sheet in the file and reads the spreadsheets into the tables. Depending on the operating system QtiPlot provides three import methods. The first one (using the ExcelFormat library) can fail for certain files, therefore QtiPlot provides a second solution which needs either OpenOffice or LibreOffice installed on your computer. On Windows platforms, if the file contains graphs, QtiPlot will also import them, but only if you have Excel installed on your machine. The import method used by QtiPlot can be set via the General tab of the Preferences dialog.

File -> Open ODF Spreadsheet

Opens a file dialog permitting you to select an OpenOffice spreadsheet file. QtiPlot can import data from spreadsheets stored in binary *.ods files as well as from flat XML *.fods files. When a file is selected and opened, QtiPlot creates a new table for each sheet in the file and reads the spreadsheets into the tables.

File-> Open Image File (Ctrl-I)

This command adds a new graph window to the QtiPlot project and loads an image file into it. The image can be resized and moved around in the graph window if desired. It can also be copied and inserted into another 2D plot with a result similar to that obtained using the Add Image. An image can also be used to generate an intensity matrix (see the Import Image... command).

File -> Append Project... (Ctrl-Alt-A)

Appends an existing QtiPlot project file (.qti) to the current project as a new folder.

This command can also be used to append projects which have been built with Origin software.

File-> Recent Projects

Opens a list of the most recently used QtiPlot project files. You can open one of these files by selecting it from the list. If the file no longer exists or has been moved, an error message will pop-up and the filename will be deleted from the list.

File -> Close

Closes current project, without quitting the application.

File-> Save Project (Ctrl-S)

Saves the current project. If the project hasn't been saved yet (an "untitled" project), a dialog will open, allowing you to save the project to a specific location. In a project file, all settings and all plots are stored in ASCII format.

If the project includes large tables, it may be useful to save the project in a compressed file format. The free zlib library is used to save files in gzip format ( .qti.gz ).

File-> Save Project as... (Ctrl-Shift-S)

Saves the current project under a file name different than the current name.

File-> Save Window as...

The Save Window as... command allows you to save tables and graphs from from one Qti project into a newly created project file. The command opens a standard file-save window in which you select the new project's name and location. Projects may be saved in either compressed or uncompressed form. If a graph window is selected, the new project will contain the graph and it's associated tables/matrices. If a table, matrix or note is chosen, the new project will contain only the selected table, matrix or note. In this case, dependent graphs are not included in the new project.

File -> Open Template

Opens an existing QtiPlot template file (.qpt). This command will create a new graph window with one or more empty layers created using the same graphical parameters (window geometry, fonts, colors, etc). as the layers in the saved template.

The first figure below is a graph which was saved as a template. The second figure is the graph with a new, empty layer created using the Open Template command to load the saved template file.

You just have to add curves with the Add/Remove Curves... command, but note that the style used to draw these curves is not kept in the template.

File -> Save as Template

Save the active graph as a QtiPlot template file (.qpt). The resulting template will contain all of the layers from the graph, including images, text labels (axes, etc), and any graphical parameters, including the positions and sizes of the layers. Plotted data, the style used to draw curves, and any associated scales are not saved in the template.

File-> Print (Ctrl-P)

Prints the active plot. A print dialog is opened where you can select the printer, different paper sizes, etc.

File-> Print Preview

Displays a print preview for the active window. You can use this dialog to print the previewed window.

File-> Print All Plots

Prints all plots in the project. A print dialog is opened where you can select the printer, different paper sizes, etc.

File -> Export Graph

The Export Graph command appears in the file menu whenever a graph window is selected. This command opens the Export Graph dialog which can be used in order to save the active graph window in a chosen image format.

Export Graph -> Current (Alt-G)

This selection will save the active graph using one of the image formats supported by QtiPlot.

Export Graph -> All (Alt-X)

This selection will save all graphs in the project using one of the image formats supported by QtiPlot.

File -> Create Open Document Presentation...

This selection will save all the graphs in the project in an Open Document Format file (.odf) that can be opened and edited with OpenOffice.

File -> Export

The Export command appears in the file menu whenever a non-graph window (i.e., Table or Matrix) is selected.

Export ASCII

This command opens the Export ASCII dialog, with which you can save the active table or matrix in a chosen ASCII format (".dat", ".html", ".odf", ".tex", ".txt", and ".xls" are available).

Export Excel

This command opens the Export ASCII dialog with the ".xls" format pre-selected. This saves the active table or matrix as an Excel spreadsheet.

Export to PDF (Ctrl-Alt-P)

This command opens a generic file dialog to save the active window as a PDF document.

File -> Import

File -> Import -> Import ASCII... (Ctrl-K)

Opens the Import dialog used to import ASCII data files. The file to import, and the options for importation are set in this dialog.

File-> Import Image...

Using this command, an image may be loaded into a QtiPlot project and converted into an intensity matrix. For each pixel, an intensity between 0 and 255 is computed from the intensities of the three colors red, green and blue.

This example shows the 3D plot drawn from the intensity matrix obtained from the QtiPlot logo.

File -> Import -> Database...

This command opens a sub-menu allowing to import database files in one of the following formats: dBase (.dbf), Microsoft Access (.mdb), SQLite (.db), MySQL and PostgreSQL. The file formats available for import may vary from one operating system to another.

If you wish to import Microsoft Access database files (.mdb) on Windows you must first install the Microsoft Access Database Engine available for download from the following link: https://www.microsoft.com/en-us/download/details.aspx?id=13255. You must, of course, pay attention to the architecture of your Windows system and install the 64-bit version of the Access Database driver if you're using a 64-bit version of QtiPlot.

Each of the commands in the database format sub-menu opens a file dialog or a server connection dialog allowing the selection of a database. After the completion of the database selection step, depending on the database format, QtiPlot might also open a table selection dialog allowing to choose the tables/views to be imported. If you choose to import an SQL database (MySQL, PostgreSQL or SQLite), this dialog also makes possible to perform an SQL query prior to the import operation.

File -> Import -> Matlab...

This command allows to import Matlab (.mat) files.

File -> Import -> Sound (WAV)...

This command allows you to import an uncompressed sound (.wav) file (PCM format).

File -> Import -> NI (TDMS)...

This command allows to import files in the TDMS format (.tdms), a file format developed by National Instruments which is optimized for saving measurement data to disk. This command opens the Open TDMS File dialog that gives total control over the import process.

File -> Quit (Ctrl-Q)

Closes the application. You will be asked whether or not you want to save any changes.