Plot Details

This dialog is activated by selecting the Plot... command from the Format Menu. It may also be activated either by a double click on a plot or by right-clicking on a plot and selecting Plot Details.... If there is more than one layer in the window, QtiPlot will select the layer which contains the plot under the mouse pointer. The exact contents of the dialog will vary depending upon how the dialog was invoked and on the type of plot item selected.

The left part of the dialog window is a tree view that shows the plot layers in the active window and the curves and objects which are plotted on each layer. All modifications will be made to the selected item (window, layer, curve or plot object). The right part of the dialog box contains several tabs which depend on the kind of item selected in tree view on the the left side of the dialog. They are described in the following subsections.

If the selected item is a plot curve than the Table, Plot Associations... and Edit Range... buttons become visible. Clicking the Plot Associations... button opens a dialog which can be used to select the columns of the table to be used as X and Y values for the active curve. Clicking the Edit Range... button opens a dialog which can be used to change the visible data range for the active curve. If the Table button is visible, it may be used to access to the table which contains the columns for the selected curve.

Dimensions

In the Dimensions tab you can accurately set the position and size of the graph window. The size can be applied to either the selected window or to all graph windows in the project. When the Keep aspect ratio option is checked, changing either the width or height will proportionally change the other dimension. It doesn't mean that the aspect of the graph window will remain unchanged when you manually resize it with the mouse. If you want to enable this fixed aspect behaviour for the graph layers, you need to visit the layer geometry tab. You should use the preferences dialog if you want to change the default behaviour for all plot layers that will be created in the future.

If the option Do not resize layers when window size changes is checked the size and position of the plot layers will remain fixed when the user changes the dimensions of the window.

Figure 5-19. The Plot Details Dialog: Dimensions tab.

Print

A graph page with dimensions that are smaller or larger than those of the printable area will be printed scaled to the dimensions of the printer page if the Scale layers to paper size option is checked.

Select the Print Cropmarks check box to display crop marks at the margins of the printer's printable area.

Figure 5-20. The Plot Details Dialog: Print tab.

Fonts

Using the push buttons in the Fonts tab you can customize with just a few clicks the fonts for various elements of all plot layers in the graph window.

Figure 5-21. The Plot Details Dialog: Fonts tab.

Miscellaneous

By checking the Link X axes option in the Miscellaneous tab, the layers in the graph window will be linked: when changing the X axis scale in one layer the X scales in the other layers will be adjusted accordingly. This behavior can be applied to the active window or to all graph windows in the project.

Figure 5-22. The Plot Details Dialog: Miscellaneous tab.

Window Display

In the window Display tab you can define the style for the background of the graph window page. By default it is filled with a solid white color, but you can set it to be filled with a color gradient. By pressing the Set As Default button these settings will be automatically applied to all graph windows created in the future.

Figure 5-23. The Plot Details Dialog: Display tab.

Legends/Titles

The Legends/Titles tab provides controls for automatic legend and title construction in QtiPlot graphs.

You can use the Translation Mode %(1), %(2) drop-down list in the Legends group box to specify the table column header information that should be used in the graph legend. The second Translation Mode drop-down list in the Auto Axis Titles box has the same utility with respect to the graph axis titles.

If the Auto-update box is checked, plot legends are updated each time a curve is added or removed from the plot layer the legends belong to. By pressing the Set As Default button these settings are saved to the user preferences and reused each time you create a new 2D plot window.

Figure 5-24. The Plot Details Dialog: Legends/Titles tab.

The Data Plot Index control is useful when plotting multiple Y columns of data against a single X column. You can use it in order to specify which data column will provide the information for the axis titles. You should be aware that when choosing the data column based on this index QtiPlot takes into account the number of curves attached to each layer axis.

If the option Show Units (when available) is selected the contents of the table column's Unit property will be appended to the axis title. All these settings can be applied to the active graph or to all 2D plot windows in the project, depending on the option you choose in the Apply to... list box on the right side of this dialog tab.

The following tabs are available when an item corresponding to a plot layer is selected in tree view on the the left side of the dialog:

Layer

In the Layer tab you can define the style properties of the plot layer: the background color/gradient and the frame around it. You can also customize the behavior of the plot layer: enable/disable Antialiasing for the drawing of data curves, Autoscaling of the axes range when the data curves are modified and automatic resizing of the fonts when the size of the plot layer is changed by the user (Scale Fonts check box).

Figure 5-25. The Plot Details Dialog: Layer properties.

Canvas

In the Canvas tab you can define the properties of the plot canvas: the background color/image and the frame around the canvas.

Figure 5-26. The Plot Details Dialog: Canvas with a solid background color.

Figure 5-27. The Plot Details Dialog: Canvas with a background image.

Geometry

The third tab defines the geometry of the drawing canvas in a plot layer. When the Keep aspect ratio option is checked, changing either the width or height will proportionally change the other dimension. Also, the ratio between the width and the height of the plot canvas will remain unchanged when you manually resize the graph window.

Figure 5-28. The Plot Details Dialog: Canvas geometry.

Speed

The Speed tab can be used to customize the speed mode for the layer. This can be very useful when dealing with very large data sets. Speed mode uses the Douglas and Peucker algorithm, the purpose of which is to take a 'curve' composed of line segments (or points) and find a new curve with fewer points that is not too dissimilar from the original curve. The algorithm defines 'not too dissimilar' as a function of the maximum distance (tolerance) between the original curve and the new curve. The new curve then consists of a subset of the line segments (or points) that defined the original curve. When the speed mode is enabled, filtering of the data is activated only for the curves with more than the specified maximum number of data points.

Figure 5-29. The Plot Details Dialog: Layer Speed Mode.

Layer Display

The layer Display tab can be used to customize the display options for the plot layer. The Data Drawing Options group box enables fine control over the way data is drawn on the plot canvas. In this tab it is possible to enable/disable the display of a drop shadow effect for all curves in a plot layer. The drawing options for the drop shadows are the color (by default it is set to dark gray), the offset (8 pixels by default) and the blur radius (5 by default).It is also possible to show/hide the drop shadow of individual plot curves via their context menu (right-click on a plot curve in order to make it pop-up).

The controls in the Axes group box can be used to enable/disable the display of individual plot axes.

Figure 5-30. The Plot Details Dialog: Layer Display.

Stack

The Stack tab can be used to customize the vertical offset between data curves. The following stacking modes are available:

None:

Data plots are not stacked.

Cumulative:

Y values of data plots are stacked cumulatively.

Constant:

Data plot points are shifted by a specified constant value that can be set in the edit box to the right of the Constant radio button.

Auto:

This is the default mode. QtiPlot calculates constant offsets based on min-max Y value difference and a specified gap. The gap value can be set in the edit box to the right of the Auto radio button.

Individual:

Each plot has individual offset settings, which can be modified on the Offset tab in the plot details dialog when the corresponding plot curve is selected in the left panel under the expanded Layer icon.

Figure 5-31. The Plot Details Dialog: Layer Display.

Group Edit

The Group Edit tab can be used to customize the appearance of all plot curves with only a few clicks. This is mainly helpful when you have a lot of data curves and you want to avoid individually editing curve style properties.

The Line Color push button in the Increment Curve Properties box is intended to be used in conjunction with the Indexed Colors list defined in the Curves tab of the Preferences dialog. By pressing this button, the line colors of all the data curves in the current plot layer will be changed according to their indices in this list of colors. The other two buttons Line Style and Pattern will change the line style and the fill patterns respectively. Please beware that by pressing the Pattern button the area bellow the curves will be automatically filled, even if it wasn't before.

Figure 5-32. The Plot Details Dialog: Group Edit tab.

The Gradient Fill box adds the possibility to apply a colour gradient to all plot curves. The line color, fill color and symbol color of all the data curves will be changed to a color in the user defined range going from Color 1 for the first curve of the plot layer to Color 2 for the last curve. This change can be applied to the current plot layer or to all the layers in the current graph window as well as to all 2D graph windows.

The same functionality can be accessed via the context menu of a layer (right-click on the layer canvas to make it pop-up). The image bellow shows the Palette sub-menu that can be used to set a gray scale gradient or a default color gradient from a red Color 1 to a blue Color 2. You can also apply the Indexed Colors default list defined in the user preferences. The Style sub-menu gives access to the Increment Line Style and Increment Fill Pattern functions explained above.

Figure 5-33. Context menu of a plot layer.

Curve axes

The Axes tab, the first tab on the right side of the dialog window, allows definition of the pair of axes to which a curve is attached. Attaching different curves on the layer to different X/Y axis pairs permits placing several curves with different x/y scales on the same plot layer.

Figure 5-34. The Plot Details Dialog: Assign Axes.

Line/Pattern

The title of this tab may be either Line or Pattern depending on the type of the selected plot curve. This tab allows customizing the style of the plot line (color, line style, thickness). The connect button allows changing the style which is used to draw the selected curve (steps, droplines, etc). See the Plot menu to see the different types of plots available.

Figure 5-35. The Plot Details Dialog: Line formatting.

Symbol

The Symbol tab can be used to select the plot symbol used for the data points and to modify its aspect (size, color, fill color, transparency). There are three categories of plot symbols available in QtiPlot: Standard, Unicode and Image symbols and you can choose one of them by clicking the corresponding radio button from the top side of this tab. Each category of symbols has its own customizable properties.

The Size drop-down list box may be used to select either a column that contains the size values for the plot symbols or a constant value. Alternatively you may type a custom constant size value. Units are measured in pixels. If the size values are taken from a table column, the Scaling Factor box becomes visible and its value may be used to proportionally increase or decrease the sizes of the plot symbols.

Figure 5-36. The Plot Details Dialog: Standard Symbol formatting.

Figure 5-37. The Plot Details Dialog: Unicode Symbol formatting.

The Original size button is available only if the symbol is an Image. This button is automatically enabled when the current size of the plot symbols is different from the original image size. If pressed, the current size settings are reverted to the original image size.

Figure 5-38. The Plot Details Dialog: Image Symbol formatting.

Labels

The Labels tab is used if you want labels plotted at each data point in the plot. Options are provided to control the font, color, rotation angle and position of these labels.

Figure 5-39. The Plot Details Dialog: Labels formatting.

Offset

The Offset tab is only available when the plot layer has the Individual stacking mode enabled. It may be used to specify custom offsets for the plot curves in both horizontal and vertical directions.

Figure 5-40. The Plot Details Dialog: Offset formatting.

Error bars

With the controls in the Direction group you can specify if the positive and/or negative side of the error bars should be drawn, by checking the Plus and/or Minus boxes. You can also specify if the error bars are horizontal or vertical by checking/unchecking the X Error Bar box.

Using the controls in the Style group box you can customize the error bars in terms of color, line width, cap width and transparency. Finally, it is possible to tell QtiPlot to skip a number of data points when drawing the error bars by specifying a positive value in the Skip Points box.

Figure 5-41. The Plot Details Dialog for formatting error bars.

Pie plots

These commands are available for pie plots. The first tab is used to customize the pie segments. The fields on the left are used to modify the border drawn around each segment. The color, type and width of line may be customized. The default is no border (line width = 0).

The fields on the right are used to define the fill style used for pie segments. The First color combo-box defines which color is used for the first segment. The remaining segments will be filled with colors that follow the order defined in the combo-box's list. The default value for this field is black, so segments 2, 3, ... will be red, green, etc.

The Pattern combo-box defines the fill pattern that will be used for all segments of the pie. The default value is solid fill.

Figure 5-42. The Plot Details Dialog for pies: Pie Segment Formatting.

Pie geometry

Figure 5-43. The Plot Details Dialog for pies: Pie Geometry.

Pie labels

Figure 5-44. The Plot Details Dialog for pies: Pie Labels Formatting.

Box/Whiskers

Figure 5-45. The Plot Details Dialog for box: Whiskers Formatting.

Percentile

Figure 5-46. The Plot Details Dialog for box: Percentile Formatting.

Data

The Distribution Curve control group makes possible to overlay a "pseudo" distribution curve on the binned data by selecting Normal, Lognormal, Poisson, Exponential, Laplace, Lorentz, Weibull, Kernel Smooth, Gamma or Binomial from the Type drop-down list. We call these curves "pseudo" distribution curves because they are not the result of a fit operation performed on the binned data. QtiPlot simply determines the data mean, then overlays the curve so that the means coincide. In the case of a two parameter distribution, the second parameter taken into account is the standard deviation of the binned data. If the Scale to Maximum box is checked an input value box becomes visible, allowing you to control the amplitude of the distribution curve.

If you click the Show Statistics button from the Bin Worksheet control group, QtiPlot creates a table containing the computed quantities of the bins and the dialog is closed. You may check the Add Distribution Curve option in order to add the data used to create the overlayed distribution curve to this bin table.

Figure 5-47. The Plot Details Dialog for box: Data Formatting.

Spacing

Figure 5-48. The Plot Details Dialog for histograms: Spacing Formatting.

Histogram Data

The Distribution Curve control group makes possible to overlay a "pseudo" distribution curve on the binned data by selecting Normal, Lognormal, Poisson, Exponential, Laplace, Lorentz, Weibull, Kernel Smooth, Gamma or Binomial from the Type drop-down list. We call these curves "pseudo" distribution curves because they are not the result of a fit operation performed on the binned data. QtiPlot simply determines the data mean, then overlays the curve so that the means coincide. In the case of a two parameter distribution, the second parameter taken into account is the standard deviation of the binned data. If the Scale to Maximum box is checked an input value box becomes visible, allowing you to control the amplitude of the distribution curve.

If you click the Show Statistics button from the Bin Worksheet control group, QtiPlot creates a table containing the computed quantities of the bins and the dialog is closed. You may check the Add Distribution Curve option in order to add the data used to create the overlayed distribution curve to this bin table.

Figure 5-49. The Plot Details Dialog for histograms: Data Formatting.

Line

This tab is only available when the selected data curve is a box curve or a histogram that also displays a distribution curve. It allows customizing the style of the distribution curve (color, line style, thickness).

Figure 5-50. The Plot Details Dialog: Distribution Curve Line formatting.

Vector

The value typed in the Length spin box determines the length of the arrowheads. Units are measured in points. The Angle value determines the arrowhead angles in degrees. You may check the Filled box to display filled arrowheads or uncheck it in order to display the hollow (transparent) arrowheads.

If the vector type is XYXY the End Point controls group is visible and you can select the column that contains the X end point values from the X End drop-down list and the column that contains the Y end point values from the Y End drop-down list.

Figure 5-51. The Plot Details Dialog for Vector XYXY curves.

If the vector type is XYAM two other control groups become visible: Vector Data and Magnitude.

Figure 5-52. The Plot Details Dialog for Vector XYAM curves.

The Angle drop-down list box from the Vector Data controls group may be used to select either a column that contains the vector angle values or a constant value. Alternatively you may type a custom constant angle value from 0 to 360 degrees. The angle is measured counterclockwise.

The Magnitude drop-down list box from the Vector Data controls group may be used to select either a column that contains the magnitude values or a constant value. Alternatively you may type a custom constant magnitude value. Units are measured either in pixels or in real world coordinates (Scale Coordinates), depending on the value selected in the Unit drop-down list box from the Magnitude controls group.

The Multiplier value from the Magnitude controls group may be used to proportionally increase or decrease the length of the vectors. For example, type 0.5 to draw the vectors at half their original length. The default value is 1.

Finally, it's worth mentioning that you may change the vector type from XYXY to XYAM and vice versa using the Plot type drop-down list box from the bottom left corner of this dialog.

Values

This tab is activated by clicking on a contour curve (or on the plotting area) when a 2D plot has been created from a matrix with one of the following commands from the Plot 3D menu: Contour+Color Fill command, Countour Lines command or Gray Scale Map command.

Figure 5-53. The Values tab.

The Values tab allows choosing the matrix that is to serve as the data source for the plot. It is possible to use a formula defined for the matrix to calculate the plotted Z values by checking the Use matrix formula to calculate values box. This results in higher accuracy, especially when drawing contour lines, but it only works if the formula uses muParser compatible syntax.

If you need higher accuracy but the source data matrix can not use an analytical formula to calculate its values you can use the controls from the Resolution group box. There you can define a larger number of Columns/Rows and press the Resample button. By doing this the dimensions of the source data matrix will be increased. The values of the new data cells are calculated using bilinear interpolation.

By pressing the x2 button the dimensions of the source matrix are doubled, the values of the new data cells being calculated using the bilinear interpolation method. The /2 button performs the opposite operation: the dimensions of the data source matrix are divided by two. It is possible to revert all the changes in resolution by pressing the Undo button.

Colors

Figure 5-54. The Colors tab.

There are two groups of controls on this tab. Each group is activated by checking the box next to the group label. The first group of controls, labeled Image, are used to select the fill type of the contour plot. It is checked when filling of the contour plot is desired. If unchecked, no fill will be used. If filling is enabled, you may choose between gray-scale, a default color mapping and a custom color mapping with the 3 radio buttons. The default gray-scale and color maps are shown in the figure below.

You can only customize the colormap when the Custom Colors option is selected. A table with a set of numbers (the Z levels), and the color corresponding to each Z level, is presented. You can then add, remove or modify levels from the definition of the colormap. The first and last levels cannot be changed. These are always set to the minimum and maximum Z values. Note that this is only the definition of the colormap - it won't change the number of contour lines in your plot. An example of classical custom colormap is given here:

As long as the Scale Colors checkbox remains checked, Z-values that fall between colormap levels will be displayed in colors that are interpolated between the colors defined for the bounding levels. It is also possible to define discrete colors for each level. To do this you must uncheck the Scale Colors checkbox. In this case, no interpolation will be done, and you must define enough levels in your colormap to produce a desirable result.

The second group of settings must be enabled if you want a bar scale on your plot. You can then define its position and width.

Contour Lines

The Contour Lines tab is used to customize settings applicable to the contour lines. You can select the number of lines and their color. If you check Use Default Pen, the color of the lines will be defined by the settings in the group of controls to the left of the checkbox. If you check Use Color Map, the lines will be colored as a function of the Z levels from the colormap defined in the Colors setting tab. If you check Use Table Custom Pen, the color of the lines will be determined by the settings defined in the Pen column of the table displaying the Z levels.

Figure 5-55. The Contour Lines tab.

Figure 5-56. The Labels tab.

The Labels tab is used to enable/disable the display of a Z value for each of the contour lines. You can globally customize the color, background, font, rotation and position of the text labels.