Preferences Dialog

The preference dialog is used to customize the default behavior of QtiPlot. There are six pages of options which are selected using one of icons from the column on the left hand side of the dialog. The text box at the top of the dialog shows the name of the selected page. No matter which page is selected, there are always seven buttons along the bottom edge of the dialog: Help, Default Options, Save As, Load Settings, Apply, OK and Cancel.

Changes must be confirmed using either the Apply or OK buttons. The OK button additionally closes the dialog. Upon confirmation, changes are saved and stored immediately. The Cancel button will not undo changes which have already been confirmed but provides a means of exiting the dialog without confirming any changes that are pending. The Default Options button will reset the values of all the settings to the program defaults.

The Help button opens the quick help window corresponding to the selected page.

Finally, the Save As... button opens a file save dialog allowing to export the user settings to a .ini or .txt file. Starting with version 0.9.9.6 user settings are saved to a file called QtiPlot.ini that is stored into a hidden subfolder called .qtiplot in the user's home directory. Therefore you can customise QtiPlot on any computer, export the settings file and load it on another computer by pressing the Load Settings button or copy it manually to the .qtiplot subfolder of your home directory in order to get the same behaviour of QtiPlot.

General Preferences

Selecting the General icon displays the General options page. The controls that control the general options are grouped onto a set of 6 tabs. Each tab references a set of related options.

Application Tab

Figure 5-80. The preferences dialog: general parameters for the application.

Controls on the Application tab are used to set application wide defaults.

The Language combo-box lists the translations available in QtiPlot. Select a language from this list. Control names, program labels, etc., will be displayed in this language.

The Style combo-box defines the style used by QtiPlot for the window decorations. These include stylistic aspects of buttons, dialog boxes, window borders and titles, etc. Available styles are those currently available in the Qt library.

The Font chooser selects the font used in the GUI (menus, dialogs, etc). It doesn't apply to plots.

The Default Scripting Language combo-box is used to set the scripting language. muParser is the default. Python will also be available if Python support has been compiled into QtiPlot.

The Undo Stack Size is the number of operations that can be undone/redone. By default it is set to ten operations. A high value for this parameter can be very costly in terms of memory consumption, especially for large matrices.

The Endline character combo-box defines the end of line convention used by QtiPlot for copy/paste operations and for exporting matrices/tables to ASCII files. The end of line convention can be set to any one of the following: Line Feed (LF), Carriage Return + Line Feed (CRLF) or Carriage Return (CR) only.

The Start New Project combo-box is used to select what type of child window, if any, is created when a new project is started. The default is for new projects to contain an empty Table window.

The Import Excel files using option allows to specify the method used by QtiPlot when trying to import Excel files. Depending on the operating system QtiPlot provides four methods. The first one (the ExcelFormat library) can fail for certain files, therefore QtiPlot provides a second solution which needs LibreOffice installed on your computer. The third solution which uses OpenOffice is obsolete and users that employed it in older versions of QtiPlot are strongly encouraged to install LibreOffice since it is much faster (the path to the soffice executable must be correctly set in the File Locations tab). Finally, on Windows platforms, if you choose the option Locally installed Excel, QtiPlot uses Microsoft Excel as a server application in order to import the data sheets and also the plots.

The Clipboard Image Format option allows to specify the method used by QtiPlot when copying plot images to clipboard. When the first method(Bitmap) is chosen QtiPlot stores the plots as raster images, while the other methods use vectorial image formats: Enhanced Metafile (.emf),the default format on Windows platforms, Encapsulated Postscript (.eps),the default on Linux platforms and Scalable Vector Graphics (.svg).

The Save Every check box is used to turn the auto-save feature on(checked) or off(unchecked). The associated textbox/spin button is used to set the autosave interval. The interval is in minutes. The textbox only accepts positive integer numeric input. All other input is ignored.

The Backup project before saving option is used to create a backup copy of the current project before saving a changed project file. This option is enabled when checked.

When checked, the Check for new versions at startup option will look for program updates on the internet each time the program is started. The default is disabled.

When checked, the Enable Autocompletion option enables the autocompletion feature of QtiPlot. Autocompletion is enabled by default in all QtiPlot editors (Notes, Script Windows, and values dialogs for matrices and tables). Completion suggestions are automatically popped-up for words that have more than two characters, but you can trigger autocompletion at any time using the shortcut Ctrl+U. Autocompletion can be disabled by unchecking the Enable autocompletion option.

When checked, the Open last project at startup option enables the feature that reloads the last active project when QtiPlot is restarted. The default is enabled.

Confirmations Tab

The General Preferences: Confirmations tab contains a set of 8 check boxes that enable/disable various warning prompts. The first six are warnings given when deleting project windows (Folders, Tables, Matrices, 2D Plots, 3D Plots, and Notes). The remaining 2 are warnings given when 1) renaming or appending windows with names that are already used in the current project, and, 2) when attempting to overwrite an existing file. All warnings are enabled by default.

Figure 5-81. The Preferences dialog: Confirmations tab.

Colors Tab

In this tab, you can change the default color for the QtiPlot workspace, the panel background color and the panel text color. Panels refer specifically to the Log Window and the Project explorer.

Figure 5-82. The Preferences dialog: Colors tab.

Numeric Format Tab

The Numeric Format tab allows customizing several aspects of numeric formatting used by QtiPlot. The Number of Decimal Digits specifies the default precision used for any calculations applied to your data in Tables and Matrices. The Decimal Separators fields allow selection of the characters used as the decimal point and the thousands separator. By default, QtiPlot uses the locale settings detected on your system. Separate fields are provided for data in tables/matrices and data copied to the clipboard. The thousands separator can be eliminated completely from tables and matrices by checking the Omit Thousands Separator option. QtiPlot will convert all the existing data in your project to the new settings when you click the Apply button.

If the option muParser uses C locale settings is checked operations like setting column/matrix values or plotting function curves require that all the data input parameters are written using the standard convention for the C programming language: the decimal point is the dot character and the thousands separator is omited. Uncheck this option in order to use the numeric format settings specified above.

Figure 5-83. The Preferences dialog: Numeric Format tab.

File Locations Tab

The File Locations tab allows you to define custom locations for the folders containing the translation files, the manual files and the Python configuration files (qtiplotrc.py and qtiUtil.py) if QtiPlot was built with Python scripting support. Default folder entries are also provided for scripts that are to be loaded at program startup.

The LaTeX Compiler and LaTeX Preamble fields are useful if you want to add TeX formated equations to 2D plots and you prefer to generate them using a compiler installed on your computer.

Figure 5-84. The preferences dialog: File Locations Tab.

Keyboard Tab

The Keyboard tab makes possible to define custom shortcuts for all actions in the menus and toolbars of QtiPlot.

Figure 5-85. The preferences dialog: Keyboard Tab.

Internet Connections Tab

Settings on the Internet Connection tab are only needed if you connect to the internet via a proxy server. If you don't now how to set these options, contact your Network Administrator or other suitably knowledgeable person.

Figure 5-86. The preferences dialog: Internet Connection Tab.

Tables Preferences

Selecting the Tables icon opens the second page of the preferences dialog which allows customizing default aspects of tables: background, text colors, and fonts for tables and labels. By checking the Display Comments in Header option, column comments will also be displayed in the table header, below the column names. If the Automatically Recalculate Column Values option is checked, all modifications in the values of a column trigger a recalculation of all columns with formulas depending on the modified column.

Figure 5-87. The Preferences dialog: table options.

2D Plot Preferences

Selecting the 2D Plots Icon opens the third page of the preferences dialog. This set of options is used to customize default aspects of 2D plots.

Options Tab

The Options tab may be used to customize the general behavior of the plot layers. Most of the changes made to these options will be applied only to newly created plots. Changing a few of these options, such as plot axis Autoscaling, scaling of fonts and the behavior on resize events will affect existant plots.

Figure 5-88. The preferences dialog: 2D plot options.

Curves Tab

The Curves tab contains a large number of controls that define the default style used when creating a new plot. The operation of these controls should be self evident.

Figure 5-89. The Preferences dialog: Curves Tab.

Error Bars Tab

The Error Bars tab contains the controls that define the default style used when adding error bars to a 2D plot curve.

Figure 5-90. The Preferences dialog: Error Bars Tab.

Axes Tab

The first panel in this tab allows to specify the dominant stylistic aspects of the plot axes like their Thickness, the visibility of the backbone line (with the help of the Draw backbones check box) and the space between the axes and their title and between the major ticks and their corresponding labels.

If you want that the axes intersect in the center of the plot layer you should check the Crossing axes layout box. With the help of the controls from this panel it is possible to precisely define the positions of the Horizontal and Vertical axes either in percentages of the plot canvas dimensions (width and height) or by specifying a custom scale value.

Using the controls in the Arrow group box it is possible to define a default end arrow shape for the Horizontal and Vertical axes only. The Left, Right, Bottom and Top axes cannot display arrows at their end point.

The Enabled axes panel controls which axes and more precisely which axes elements will be visible in a new plot layer. With the use of the Show check box it is possible to enable/disable a plot axis. The display of the major tick labels is controlled with the Labels check box. If you want to disable the display of an axis title you simply remove the text in the Title edit box.

Figure 5-91. The Preferences dialog: Axes Tab.

Ticks Tab

The Ticks tab defines the default style for axis ticks drawn on newly created plots. The option Max Number can be used in order to set a limit for the number of major ticks that are displayed on each axis if the plot layer is rescaled automatically, for example after using the Rescale To Show All command.

Figure 5-92. The Preferences dialog: Ticks Tab.

Grid Tab

The Grid tab defines the default aspect of plot layer grids.

Figure 5-93. The Preferences dialog: Grid Tab.

Geometry Tab

The Geometry tab defines the default size for the drawing area of a plot layer and the margins around the layers. When the Keep aspect ratio option is checked, changing either the width or height will proportionally change the other dimension. Also, the aspect of the plot canvas (ratio between width and height) will remain unchanged for all future plot layers when you manually resize a graph window.

Figure 5-94. The Preferences dialog: Geometry Tab.

Speed Tab

The Speed tab lets the user enable/disable antialiasing when drawing/redrawing 2D plots. Antialiasing is a major source of slow-down when rendering 2D plots. Unchecking the Antialiasing checkbox disables antialiasing for all curves, which probably will only be needed in extreme circumstances. Checking the Disable for curves with more than checkbox will disable antialiasing only for curves having data sets larger than the threshold set with the textbox to the right of the Disable for curves with more than checkbox. Disabling this option is probably not a good idea. The default is for both of these options to be enabled, with a threshold of 1000 data points. Proper setting of these options is essential to keeping the application responsive.

The option Disable mouse tracking for curves with more than ... data points can be used to stop detecting the position of the mouse pointer for curves with a very large number of data points. Data tools like the Data Reader command or the Select Data Range command will no longer work for the curves with more data points than the value defined for this option, but the application will be more responsive.

Figure 5-95. The Preferences dialog: Speed Tab.

Fonts Tab

The Fonts tab defines the default fonts used when creating new plots. Options are provided for the plot Title, plot Legend, Axes Labels, and Axes Numbers.

Figure 5-96. The Preferences dialog: Fonts Tab.

Print Tab

The Print tab allows you to control a few default options that are used when printing 2D plots. If you want layers to be printed with their original dimensions, you must be sure to uncheck the Scale layers to paper size option. Checking the Print Cropmarks option ensures that some visible marks will be drawn around the borders of the plot.

Figure 5-97. The Preferences dialog: Print Tab.

3D Plot Preferences

Selecting the 3D Plots Icon opens the fourth page of the preferences dialog. This set of options is used to customize default aspects of three dimensional plots. Most of the options are self-explanatory. However, the Resolution option needs clarification. This option is more or less akin to a speed drawing mode, which can be very useful when working with large data sets. Larger values of the Resolution option result in fewer data points being drawn on 3D plots, and therefore a higher drawing speed. When Resolution is set to 1, all data points are drawn.

Figure 5-98. The preferences dialog: 3D plot options.

Notes Preferences

Selecting the Notes Icon opens the fifth page of the preferences dialog. This set of options is used to customize some of the default characteristics of the text editors, such as the length of the TAB character and the font. The user can also specify whether or not line numbers should be displayed. Displaying the line numbers can be particularly helpful when debugging Python scripts.

Figure 5-99. The preferences dialog: note options.

Fitting Preferences

Selecting the Fitting Icon opens the sixth page of the preferences dialog. This page is used to set default fitting options. Most of the options are standard and straightforward. The Generated Fit Curve options may be confusing at first glance. While it may be typical to plot a fit curve as y=f(x) using the original X data that was used in the fitting operation, QtiPlot provides the alternative (by selecting the Uniform X Function option) of plotting the curve using a user specified number of X data points (default=100) uniformly spaced over the X range of the fit. Since linear fits are completely defined by 2 points, you can also have QtiPlot default to simply plotting linear fits using 2 data points by checking the 2 points for linear fits option.

If the Apparent Fit option is checked, QtiPlot uses the apparent values for fitting, according to the current axis scales. For example, select this box to fit exponentially decaying data with a straight line fit when data are plotted on a log scale. When this check box is selected and the data has error values associated with it, QtiPlot uses the larger of the positive/negative errors as weight. Apparent Fit is only useful when you fit from a graph and change the plot axis type (from Linear to Log10, for example). If you check this option, QtiPlot will first transform raw data into new data space as specified in the graph axis type, and then fit the curve with the new data. Otherwise, QtiPlot always fits raw data directly, regardless of the axis type. Apparent fit is equivalent to direct fit if you first transform raw data on the worksheet, and leads to completely different results from direct fit if your graph axis is non-linear.

Figure 5-100. The preferences dialog: fitting options.