Preferences Dialog

The preference dialog is used to customize the default behavior of QtiPlot. There are six pages of options which are selected using one of icons from the column on the left hand side of the dialog. The text box at the top of the dialog shows the name of the selected page. No matter which page is selected, there are always seven buttons along the bottom edge of the dialog: Help, Default Options, Save As, Load Settings, Apply, OK and Cancel.

Changes must be confirmed using either the Apply or OK buttons. The OK button additionally closes the dialog. Upon confirmation, changes are saved and stored immediately. The Cancel button will not undo changes which have already been confirmed but provides a means of exiting the dialog without confirming any changes that are pending. The Default Options button will reset the values of all the settings to the program defaults.

The Help button opens the quick help window corresponding to the selected page.

Finally, the Save As... button opens a file save dialog allowing to export the user settings to a .ini or .txt file. Starting with version 0.9.9.6 user settings are saved to a file called QtiPlot.ini that is stored into a hidden subfolder called .qtiplot in the user's home directory. Therefore you can customise QtiPlot on any computer, export the settings file and load it on another computer by pressing the Load Settings button or copy it manually to the .qtiplot subfolder of your home directory in order to get the same behaviour of QtiPlot.

General Preferences

Selecting the General icon displays the General options page. The controls that control the general options are grouped onto a set of seven tabs. Each tab references a set of related options.

Application Tab

Figure 5-137. The preferences dialog: general parameters for the application.

Controls on the Application tab are used to set application wide defaults.

The Language combo-box lists the translations available in QtiPlot. Select a language from this list. Control names, program labels, etc., will be displayed in this language.

The Style combo-box defines the style used by QtiPlot for the window decorations. These include stylistic aspects of buttons, dialog boxes, window borders and titles, etc. Available styles are those currently available in the Qt library.

The Font chooser selects the font used in the GUI (menus, dialogs, etc). It doesn't apply to plots.

The Default Scripting Language combo-box is used to set the scripting language. muParser is the default. Python will also be available if Python support has been compiled into QtiPlot.

The Undo Stack Size is the number of operations that can be undone/redone. By default it is set to ten operations. A high value for this parameter can be very costly in terms of memory consumption, especially for large matrices.

The Endline character combo-box defines the end of line convention used by QtiPlot for copy/paste operations and for exporting matrices/tables to ASCII files. The end of line convention can be set to any one of the following: Line Feed (LF), Carriage Return + Line Feed (CRLF) or Carriage Return (CR) only.

The Start New Project combo-box is used to select what type of child window, if any, is created when a new project is started. The default is for new projects to contain an empty Table window.

The Import Excel files using option allows to specify the method used by QtiPlot when trying to import Excel files. Depending on the operating system QtiPlot provides four methods. The first one (the ExcelFormat library) can fail for certain files, therefore QtiPlot provides a second solution which needs LibreOffice installed on your computer. The third solution which uses OpenOffice is obsolete and users that employed it in older versions of QtiPlot are strongly encouraged to install LibreOffice since it is much faster (the path to the soffice executable must be correctly set in the File Locations tab). Finally, on Windows platforms, if you choose the option Locally installed Excel, QtiPlot uses Microsoft Excel as a server application in order to import the data sheets and also the plots.

The Clipboard Image Format option allows to specify the method used by QtiPlot when copying plot images to clipboard. When the first method (Bitmap) is chosen QtiPlot stores the plots as raster images, while the other methods use vectorial image formats: Enhanced Metafile (.emf), the default format on Windows platforms, Encapsulated Postscript (.eps), the default on Linux platforms and Scalable Vector Graphics (.svg).

The Preview check box allows to enable/disable the display of a preview image in the project explorer when the user hovers the mouse over the name of a project window. The size of the preview can be customized using the spin box on the right. The preview image is scaled to a rectangle preserving the aspect ratio of the window and having the shorter side equal to the value displayed in the spin box. When the Preview box is not checked, the display of the preview image is disabled during mouse hover events, but the user can still preview the window using the context menu of the window item. The context menu is displayed with a right-click.

The Save Every check box is used to turn the auto-save feature on(checked) or off(unchecked). The associated textbox/spin button is used to set the autosave interval. The interval is in minutes. The textbox only accepts positive integer numeric input. All other input is ignored.

On macOS systems, starting with release 10.14 (Mojave), the Theme list box is available. It can be used in order to force the usage of the Light or Dark theme, despite the settings in the general system preferences. If the selected theme is Auto, QtiPlot honours the system preferences.

If the option Backup project before saving is checked, QtiPlot creates a backup copy of the current project before saving any changes. This option is checked by default. The QtiPlot backup files have the extension *.qti~. If QtiPlot closes unexpectedly, the current project file might be corrupted, but it is still possible to recover the initial state of the file which is stored in the .qti~ backup copy. This file can be opened using the Open command and selecting the option Backup files (*.qti~) from the list of supported file types.

When checked, the Check for new versions at startup option will look for program updates on the internet each time the program is started. The default is disabled.

When checked, the Enable Autocompletion option enables the autocompletion feature of QtiPlot. Autocompletion is enabled by default in all QtiPlot editors (Notes, Script Windows, and values dialogs for matrices and tables). Completion suggestions are automatically popped-up for words that have more than two characters, but you can trigger autocompletion at any time using the shortcut Ctrl+U. Autocompletion can be disabled by unchecking the Enable autocompletion option.

When the option Enable window changelog is checked, the information displayed in the undo/redo stack is logged internally for each table or matrix window in the project and saved into the project file. This information can be viewed at any time by pressing the Changelog... button in the Window Properties dialog of each table/matrix window.

When checked, the Open last project at startup option enables the feature that reloads the last active project when QtiPlot is restarted. The default is enabled.

Confirmations Tab

The General Preferences: Confirmations tab contains a set of check boxes that enable/disable various warning prompts. The first six are warnings given when deleting folders or closing project windows (Tables, Matrices, 2D Plots, 3D Plots and Notes).

The remaining warnings are given when renaming or appending windows with names that are already used in the current project, when pasting values to tables, when evaluating multi-line expressions using muParser, when attempting to overwrite an existing file and when modifying data points using the 2D plot tools. All warnings are enabled by default.

Figure 5-138. The Preferences dialog: Confirmations tab.

Colors Tab

Using the controls from the General group box, it is possible to change the default color for the QtiPlot workspace, the panel background color and the general color of the text. Panels refer for example to the Log Window or the Project explorer.

The controls from the Matrix group box can be used to change the default background and text colors for matrix windows.

Figure 5-139. The Preferences dialog: Colors tab.

Numeric Format Tab

The Numeric Format tab allows customizing several aspects of numeric formatting used by QtiPlot. The Number of Decimal Digits specifies the default precision used for any calculations applied to your data in Tables and Matrices. The Decimal Separators fields allow selection of the characters used as the decimal point and the thousands separator. By default, QtiPlot uses the locale settings detected on your system. Separate fields are provided for data in tables/matrices and data copied to the clipboard. The thousands separator can be eliminated completely from tables and matrices by checking the Omit Thousands Separator option. QtiPlot will convert all the existing data in your project to the new settings when you click the Apply button.

If the option muParser uses C locale settings is checked operations like setting column/matrix values or plotting function curves require that all the data input parameters are written using the standard convention for the C programming language: the decimal point is the dot character and the thousands separator is omited. Uncheck this option in order to use the numeric format settings specified above.

Figure 5-140. The Preferences dialog: Numeric Format tab.

File Locations Tab

The File Locations tab allows you to define custom locations for the folders containing the translation files, the manual files and the Python configuration files (qtiplotrc.py and qtiUtil.py) if QtiPlot was built with Python scripting support.

The folder entry Startup Scripts is empty by default. This control is only visible if QtiPlot was built with Python scripting support and if the Default scripting language is set to Python in the Application tab of this dialog. In this folder one may place all the Python script files (*.py) that should be loaded and executed when QtiPlot starts.

The LaTeX Compiler and LaTeX Preamble fields are useful if you want to add TeX formated equations to 2D plots and you prefer to generate them using a compiler installed on your computer. The LaTeX Preamble field is optional, you may leave it blank.

In the LaTeX Compiler field you must provide the path to the LaTeX executable. On Linux this path is set by default to /usr/bin/latex. On Windows operating systems you need to choose the location of the latex.exe file. A very popular LaTeX compiler for Windows is MiKTeX. On macOS you can use the LaTeX distribution provided by the MacPorts project. In this case the path to the LaTeX executable is probably /opt/local/bin/latex.

Figure 5-141. The preferences dialog: File Locations Tab.

Keyboard Tab

The Keyboard tab makes possible to define custom shortcuts for all actions in the menus and toolbars of QtiPlot.

Figure 5-142. The preferences dialog: Keyboard Tab.

Internet Connections Tab

Settings on the Internet Connection tab are only needed if you connect to the internet via a proxy server. If you don't now how to set these options, contact your Network Administrator or other suitably knowledgeable person.

Figure 5-143. The preferences dialog: Internet Connection Tab.

Tables Preferences

Options Tab

Selecting the Tables icon opens the second page of the preferences dialog which allows customizing default aspects of tables: background, text colors and fonts for tables and labels.

Figure 5-144. The Preferences dialog: table options.

If the Automatically Recalculate Column Values option is checked, all modifications in the values of a column trigger a recalculation of all columns with formulas depending on the modified column.

The controls in the Columns group box can be used to select the default column Type and Numeric Format. The Alignment selection box can be used to define the default position of the text in the table cells: the text can be aligned with the left or right edge of the columns or centered horizontally in the available space.

The controls in the Display group box can be used to select what information is visible in the the table header below the column names. Available options are the Long Names, the Units, the column Comments and the column formulas, F(x).

The Preview group box can be used to define the size of the picture that is displayed for each table column after a right click on the colum header. Unchecking this group box disables the display of the preview picture.

Checking the Scale to paper size option from the Print group box, ensures that the width of large table windows will fit onto the paper when printed. This is achieved by scaling horizontally the table columns. This option is checked by default.

When creating a 3D plot from a Z table column, QtiPlot generates a hidden matrix window that is used to store the data for the plot window. The controls in the Convert to Matrix - Regular XYZ group box allow to customize this process of generating a hidden matrix from a table that contains regularly spaced XY data.

In order for the input data to be classified as regular, the values in the X and Y columns must meet specific requirements: both the X and the Y data values must be equally spaced, only small irregularities of the data are allowed. The value of the tolerance for irregularities in both X and Y directions can be customized via the Tolerance for Duplicate X and Tolerance for Duplicate Y input boxes, respectively. These two input values must be between 0 and 1.

The Replace Duplicates With list box is useful if several Z values correspond to the same XY data pairs within the user specified tolerances. The user can choose how these Z values should be combined into a single value. The possible ways to generate a single Z value are:

Mean:

the mean of the duplicate Z values is used (default functioning mode).

Minimum Value:

the minimum Z value is used.

Maximum Value:

the maximum Z value is used.

Sum:

the sum of the duplicate Z values is used.

None:

the last of the duplicate Z values is used.

Descriptive Statistics Tab

Via this tab you can select the quantities to be computed and displayed in the columns of the result tables generated by the Statistics -> Descriptive Statistics -> Statistics on Columns and Statistics -> Descriptive Statistics -> Statistics on Rows commands.

Figure 5-145. The Preferences dialog: descriptive statistics options.

The following Moments can be computed by QtiPlot:

N

The number of valid values, Xi, in the dataset. Empty data cells are ignored.

Mean

The arithmetic mean of the dataset:

Standard deviation (SD)

The standard deviation is defined as the square root of the variance:

Standard error

SD/N1/2

Variance

Sum

The sum of all values in the dataset:

Skewness

The skewness measures the asymmetry of the tails of a distribution. It is calculated using the following formula:

Kurtosis

The kurtosis measures how sharply peaked a distribution is, relative to its width. It is normalized to zero for a Gaussian distribution:

Before computing the following Quantiles, QtiPlot sorts the input dataset in ascending order.

Minimum Value

The first value in the sorted dataset.

Index of Minimum Value

The index number of the minimum value in the original (unsorted) dataset.

Q1 (1st Quartile)

First (25%) quantile.

Median

The median is the second (50%) quantile, Q2.

Q3 (3rd Quartile)

Third (75%) quantile.

Maximum Value

The last value in the sorted dataset.

Index of Maximum Value

The index number of the maximum value in the original (unsorted) dataset.

Interquartile Range (IQR)

The interquartile range is a measure of the statistical dispersion, being equal to the difference between the third and first quantiles: IQR = Q3 - Q1.

Custom Percentiles

You can also define a list of custom percentiles. Only integer percentile values between 1 and 99 are accepted. They must be separated by a whitespace character.

2D Plot Preferences

Selecting the 2D Plots Icon opens the third page of the preferences dialog. This set of options is used to customize default aspects of 2D plots.

Options Tab

The Options tab may be used to customize the general behavior of the plot layers. Most of the changes made to these options will be applied only to newly created plots. Changing a few of these options, such as plot axis Autoscaling, scaling of fonts and the behavior on resize events will affect existant plots.

The controls in the Layer group box can be used in order to set a default background and a solid border for each 2D plot layer and to customise the Canvas Color, where the canvas is the drawing area for 2D plot curves.

The controls in the Window group box can be used in order to set a default background and a frame for each newly created 2D plot window.

The controls in the Data Drawing Options group box can be used in order to set the default drawing options that can be modified later on for each plot layer via the Layer Display tab of the Plot Details dialog.

If the Margins box is checked QtiPlot automatically adds some amount of space before and after the data values along each axis scale. The effect of this option is mainly visible when creating new plots from table columns or when rescaling a plot layer so that all data on the graph is visible, using the Graph -> Rescale To Show All command.

The names of the other options in this group box should be self explaining.

Figure 5-146. The preferences dialog: 2D plot options.

Curves Tab

The Curves tab contains a large number of controls that define the default style used when creating a new plot.

The controls in the Indexed Colors group box can be used in order to customize the incremental list of default colors used by QtiPlot when plotting a group of data sets or for filling the segments of pie charts. The Palettes box provides four color lists: Default, LibreOffice, Origin1 and Origin2. These palettes can be loaded into the color list editor by pressing the Apply button next to the Palettes list box.

The indexed color list can be edited using the tool buttons on the right side: the New Color button, the Delete Color button, the Move Color Up button and the Move Color Down button. It is possible to save a custom indexed color list to a text file (*.txt), by pressing the Save As... button. The structure of this file is very simple: the colors are saved one per line, using the RGB format #RRGGBB. The text file can be loaded later on into the color list editor by pressing the Open File... button.

Figure 5-147. The Preferences dialog: Curves Tab.

Error Bars Tab

The Error Bars tab contains the controls that define the default style used when adding error bars to a 2D plot curve.

Figure 5-148. The Preferences dialog: Error Bars Tab.

Axes Tab

The first panel in this tab allows to specify the dominant stylistic aspects of the plot axes like their Thickness, the visibility of the backbone line (with the help of the Draw backbones check box) and the space between the axes and their title and between the major ticks and their corresponding labels.

If you want that the axes intersect in the center of the plot layer you should check the Crossing axes layout box. With the help of the controls from this panel it is possible to precisely define the positions of the Horizontal and Vertical axes either in percentages of the plot canvas dimensions (width and height) or by specifying a custom scale value.

Using the controls in the Arrow group box it is possible to define a default end arrow shape for the Horizontal and Vertical axes only. The Left, Right, Bottom and Top axes cannot display arrows at their end point.

The Enabled axes panel controls which axes and more precisely which axes elements will be visible in a new plot layer. With the use of the Show check box it is possible to enable/disable a plot axis. The display of the major tick labels is controlled with the Labels check box. If you want to disable the display of an axis title you simply remove the text in the Title edit box.

Figure 5-149. The Preferences dialog: Axes Tab.

Ticks Tab

The Ticks tab defines the default style for axis ticks drawn on newly created plots. The option Max Number can be used in order to set a limit for the number of major ticks that are displayed on each axis if the plot layer is rescaled automatically, for example after using the Rescale To Show All command.

Figure 5-150. The Preferences dialog: Ticks Tab.

Grid Tab

The Grid tab defines the default aspect of plot layer grids.

Figure 5-151. The Preferences dialog: Grid Tab.

Geometry Tab

The Geometry tab defines the default size for the drawing area of a plot layer and the margins around the layers. When the Keep aspect ratio option is checked, changing either the width or height will proportionally change the other dimension. Also, the aspect of the plot canvas (ratio between width and height) will remain unchanged for all future plot layers when you manually resize a graph window.

Figure 5-152. The Preferences dialog: Geometry Tab.

Speed Tab

The Speed tab lets the user enable/disable antialiasing when drawing/redrawing 2D plots. Antialiasing is a major source of slow-down when rendering 2D plots. Unchecking the Antialiasing checkbox disables antialiasing for all curves, which probably will only be needed in extreme circumstances. Checking the Disable for curves with more than checkbox will disable antialiasing only for curves having data sets larger than the threshold set with the textbox to the right of the Disable for curves with more than checkbox. Disabling this option is probably not a good idea. The default is for both of these options to be enabled, with a threshold of 1000 data points. Proper setting of these options is essential to keeping the application responsive.

The option Disable mouse tracking for curves with more than ... data points can be used to stop detecting the position of the mouse pointer for curves with a very large number of data points. Data tools like the Data Reader command or the Select Data Range command will no longer work for the curves with more data points than the value defined for this option, but the application will be more responsive.

Figure 5-153. The Preferences dialog: Speed Tab.

Fonts Tab

The Fonts tab defines the default fonts used when creating new plots. Options are provided for the plot Title, plot Legend, Axes Labels, and Axes Numbers.

Figure 5-154. The Preferences dialog: Fonts Tab.

Print Tab

The Print tab allows you to control a few default options that are used when printing 2D plots. If you want layers to be printed with their original dimensions, you must be sure to uncheck the Scale layers to paper size option. Checking the Print Cropmarks option ensures that some visible marks will be drawn around the borders of the plot.

Figure 5-155. The Preferences dialog: Print Tab.

3D Plot Preferences

Options Tab

Selecting the 3D Plots Icon opens the fourth section of the preferences dialog. This set of options is used to customize default aspects of three dimensional plots.

The first page in this section is the Options tab, which allows to set a default size for 3D plot windows as well as default rotation angles around the three axes. Please note that the default size is the canvas size, it doesn't include the window frame.

Figure 5-156. The preferences dialog: 3D plot options tab.

The color buttons in the Colors group box help define the aspect of the various plot elements like the axes, the scale numbers, the window background, etc... Their meaning should be self-explanatory.

The Smooth Line check box from the General controls group can be used to enable/disable the OpenGL GL_LINE_SMOOTH option: if enabled, QtiPlot draws antialiased lines, otherwise all lines are aliased.

If the Autoscaling option is checked, QtiPlot will automatically update the scale ranges for the three axes when the source data sets of the 3D curves/surfaces in a 3D plot are modified.

The Scale Fonts option enables the automatic change of the font sizes used for the various 3D plot elements with the size of the plot window. By default, this option is disabled, since it might lead to wrong results in some special cases.

Curves Tab

The second page in this section is the Curves tab, which allows to set the default preferences for 3D curves and surfaces.

Figure 5-157. The Preferences dialog: 3D curves tab.

The Style list box can be used to define the default appearance for 3D analytical functions or parametrical surfaces. Available styles are: Wireframe, Hidden line, Polygon only, Mesh + Filled polygons, Scatter and Bars.

The Floor style list box allows to define the floor projection of a 3D surface. One can enable a full 2D projection or only display the isolines. The following floor projection styles are available: Empty (the default), Isolines (the isoline projections are visible) and Projection (the 2D projected polygons are visible). If the floor style is set to Isolines, the number of projected isolines can be customised using the Isolines input box bellow.

The Shading defines the way the 3D polygons are rendered. The following shading styles are available:

Flat

The GL_FLAT shading mode from OpenGL: the color of a polygon in the 3D surface is given by only one of its vertices.

Smooth

The GL_SMOOTH shading mode from OpenGL: the colors of all vertices composing a polygon are interpolated, assigning different colors to each resulting pixel fragment of the rendered surface.

Isolines

The polygons composing the rendered surface are filled to the isoline contours.

Isolines 2

Same as previous method: the polygons composing the rendered surface are filled to the isoline contours. This method is less accurate than Isolines and may fail for very complex data, but is a litle bit faster and gives nicer results for smooth surfaces.

If the Legend option is checked, QtiPlot automatically displays a legend item for each curve or surface added to a 3D plot window. The text of the legend item has the syntax %(index), where the % character is an alias for the name of the data set and the integer value between the round brackets is the index of the curve/surface. The drop list box on the right becomes available only is the Legend box is checked and allows to select the translation mode for the % character.

The Y drop list box can be used in order to specify the way to calculate the Y values that are used for XYY plot curves. In the Auto mode the Y value is equal to the index of the 3D XYY curve. In the case of the other modes: Long Name, Units and Comments, QtiPlot reads the Y values from the corresponding fields of the Y column used to create the XYY curve.

The controls in the Mesh group box define the aspect of the lines that are drawn in the case of 3D curves or surfaces having the Wireframe, Hidden line, Mesh + Filled polygons or Line + Symbols style.

The controls in the Fill area under curve group box define the default color used to fill the area bellow a 3D curve drawn by the Waterfall Plot and Waterfall Plot (Color Mapped) commands, as well as the possibility to draw the Side Lines and the Baseline.

The Skip Points option from the Data Drawing Option control box is more or less akin to a speed drawing mode, which can be very useful when working with large data sets. Larger values of the Skip Points option result in fewer data points being drawn on 3D plots, and therefore a higher drawing speed. When Skip Points is set to 0, all data points are drawn.

If the Margins box is checked, QtiPlot automatically adds some amount of space before and after the data values along each axis scale, in an attempt to find reasonable scale ranges. The effect of this option is mainly visible when creating new plots from table columns or when rescaling a plot layer so that all data on the graph is visible, using the Graph -> Rescale To Show All command.

Axes Tab

Using the Axes tab it is possible to fully customize the appearance of the coordinates system in a 3D plot.

Figure 5-158. The Preferences dialog: 3D axes tab.

The following coordinate system styles are available:

Box

The coordinate system is drawn as a box: all 12 axes are visible, but only three of them are decorated with ticks and numbers. When this default style is chosen, it is possible to hide one of these 12 axes, using the Hide axis option, so that the result is a coordinate system with four sides.

Frame

Only three axes are visible.

1/2 Box (Right)

Three sides of the box are visible: the right side, the back and the floor.

1/2 Box (Left)

Three sides of the box are visible: the left side, the back and the floor.

By default, the three axes decorated with ticks and numbers are X1, Y1 and Z1. By setting the Enabled axes option to Custom, it is possible to specify which axes should be decorated, using the X, Y and Z drop lists that are enabled in this case.

The perspective view mode can be enabled/disabled by default using the Orthogonal box.

Grids Tab

If the coordinate system is visible, you can enable the display of a default grid for each of its six sides, by checking the corresponding boxes from the Show group box.

Figure 5-159. The Preferences dialog: 3D grids tab.

The default color, pen style and line width can be customized for both major and minor grid lines, using the controls from the Format group box.

Planes Tab

Using the Planes tab, it is possible to set a color filling for the six sides of the coordinate system. Please note that transparency of these planes is not correctly handled when exporting 3D plots to vectorial image formats (*.EPS, *PDF or *.SVG files). It is also possible to set a default colored Border for the sides of the coordinate system.

Figure 5-160. The Preferences dialog: 3D planes tab.

Colors Tab

The Colors tab makes possible to define a default color map to be used for rendering 3D surfaces with style set to Polygon only or Mesh + Filled polygons and for the symbols of 3D curves.

If the Scale Colors box is checked, a Z value will be represented by a color defined as a linear interpolation between the adjacent values in the color table.

It is possible to load or store a colormap from/to a XML file by pressing the Open file and Save buttons.

A click on the Level column header opens the Set Equidistant Levels dialog, which allows to quickly edit the color map levels by specifying their total number and an intensity range.

A click on the Color column header opens the Gradient Fill dialog, which allows to quickly customize the colors in the map.

The Opacity slider can be used in order to modify the alpha channel of the color map from 0 % (totally transparent) to 100 % (fully opaque).

Figure 5-161. The Preferences dialog: 3D colors tab.

Fonts Tab

Using the controls in the Fonts tab you can customize with just a few clicks the fonts for the various elements in a 3D plot: title, axes labels and scale numbers. The Labels font, the last in the list, is used by QtiPlot for new legend items and text objects, as well as for the curve labels that can be displayed near each data point.

Figure 5-162. The Preferences dialog: 3D fonts tab.

Notes Preferences

Selecting the Notes Icon opens the fifth page of the preferences dialog. This set of options is used to customize some of the default characteristics of the text editors, such as the length of the TAB character and the font. The user can also specify whether or not line numbers should be displayed. Displaying the line numbers can be particularly helpful when debugging Python scripts.

Figure 5-163. The preferences dialog: note options.

Fitting Preferences

Selecting the Fitting Icon opens the sixth page of the preferences dialog. This page is used to set default fitting options. Most of the options are standard and straightforward.

The Generated Fit Curve options may be confusing at first glance. While it may be typical to plot a fit curve as y=f(x) using the original X data that was used in the fitting operation, QtiPlot provides the alternative (by selecting the Uniform X Function option) of plotting the curve using a user specified number of X data points (default=100) uniformly spaced over the X range of the fit. Since linear fits are completely defined by 2 points, you can also have QtiPlot default to simply plotting linear fits using 2 data points by checking the 2 points for linear fits option.

Figure 5-164. The preferences dialog: fitting options.

The options in the Curves group box can be used to specify if additional curves should be displayed after each fit operation. If the Conf. Bands and Pred. Bands options are checked QtiPlot generates confidence bands and prediction bands, based on the user defined value for the confidence level. If the Residuals Plot option is checked the curve of the fit residuals is also generated. The residuals are calculated as the difference between the experimental values and the response values predicted by the fit model.

The controls in the Parameters Output group box can be used in order to define the default options for the display of the results from data fit operations. The Format list box allows to choose a default numerical format. The value of the Significant Digits option can be used to customize the precision of the output and has a different meaning depending on the numeric format. The following format and precision options are available:

Default

- Decimal or scientific e-notation, whichever is the most concise. The value of the Significant Digits control represents the maximum number of significant figures in the output (trailing zeroes are omitted).

Decimal: 1000

- Decimal notation. The value of the Significant Digits control represents the number of digits after the decimal point.

Scientific: 1E3

- Scientific e-notation where the letter e is used to represent "times ten raised to the power of" and is followed by the value of the exponent. The value of the Significant Digits control represents the number of digits after the decimal point.

The errors on the fit parameters are displayed in the log window only if the Error box from the Results Log group is checked. The Scale Errors with sqrt(Chi^2/doF) option only affects the errors on the parameters reported after the fit operation. It does not affect the fitting process or the data in any way. If checked, the reported errors on the parameters, εj, are calculated as the square root of the diagonal elements of the covariance matrix Cov(j, j) multiplied with sqrt(Chi2/(n - p)), where n is the number of data points and p the number of fit parameters. Otherwise, the reported errors equal the square root of the diagonal elements of the covariance matrix Cov(j, j).

If the LCL and UCL options from the Results Log group box are checked QtiPlot also displays the confidence limits for each fit parameter based on the value of the confidence level specified in the Curves box.

The controls in the Statistics group box can be used in order to define the default fit statistics to be displayed in the results log window after data fit operations. For more details about the meaning of these values, please visit the Data fiting section from the chapter dedicated to the Analysis of data and curves.

For all data analysis operations, not only fitting, there is a mechanism introduced in release 0.9.9.11 of QtiPlot that allows to trigger a recalculation when the data source is modified. It is possible to specify the desired recalculation mode using the Recalculate list box. The available options are:

No

- No recalculation when data changes.

Auto

- A recalculation is automatically performed when input data changes. This is the default option.

Manual

- No recalculation is triggered when data changes, instead the user can perform a recalculation at any time by pressing the Recalculate button from the Analysis tab of the plot details dialog.

Please note that if the recalculation mode is set to No the fit object is deleted from memory when the operation ends. In the other two cases the fit object is attached to the result plot curve and stored into the memory of the output graph window. The recalculation mode can be changed later on via the Analysis tab of the plot details dialog.

If the Apparent Fit option is checked, QtiPlot uses the apparent values for fitting, according to the current axis scales. For example, select this box to fit exponentially decaying data with a straight line fit when data are plotted on a log scale. When this check box is selected and the data has error values associated with it, QtiPlot uses the larger of the positive/negative errors as weight. Apparent Fit is only useful when you fit from a graph and change the plot axis type (from Linear to Log10, for example). If you check this option, QtiPlot will first transform raw data into new data space as specified in the graph axis type, and then fit the curve with the new data. Otherwise, QtiPlot always fits raw data directly, regardless of the axis type. Apparent fit is equivalent to direct fit if you first transform raw data on the worksheet, and leads to completely different results from direct fit if your graph axis is non-linear.