Surface plot options

This dialog box is used to customize 3D plots. It is activated by a double click on a 3D plot.

General Tab

The General tab is used to define some global parameters and the aspect ratio of the plot.

Figure 5-180. The general 3D plot options tab.

You can use the Translation Mode %(1), %(2) drop-down list in the Legends group box to specify the table column header information that should be used in the curve legends. The second Translation Mode drop-down list in the Auto Axis Titles box has the same utility with respect to the graph axis titles.

The Data Plot Index control is useful when plotting multiple Y columns of data against a single X column. You can use it in order to specify which data column will provide the information for the axis titles.

If the option Show Units (when available) is selected the contents of the table column's Unit property will be appended to the axis title.

Using the controls in the Animation group box, it is possible to define suitable rotation steps around the three axes. These parameters become the default settings for all newly created 3D plot windows.

It is possible to start/stop animating the active 3D plot by pressing the Animation button. After the animation process is stopped, one might want to reset the rotation angles around the three axes to the default values. This can be done by pressing the Reset rotation button.

By checking the Scale to paper size option from the Print group box, a 3D graph with dimensions that are smaller or larger than those of the printable area will be printed scaled to the dimensions of the printer page. It is possible to check the Print Cropmarks box in order to display dashed lines at the margins of the printable area of the 3D plot.

All these settings can be applied to the active window or to all 3D plot windows in the project, depending on the option you choose in the Apply to list box.

Axes Tab

Using the Axes tab it is possible to fully customize the appearance of the coordinates system in a 3D plot.

Figure 5-181. The general 3D plot axes tab.

The following coordinate system styles are available:

Box

The coordinate system is drawn as a box: all 12 axes are visible, but only three of them are decorated with ticks and numbers. When this default style is chosen, it is possible to hide one of these 12 axes, using the Hide axis option, so that the result is a coordinate system with four sides.

Frame

Only three axes are visible.

1/2 Box (Right)

Three sides of the box are visible: the right side, the back and the floor.

1/2 Box (Left)

Three sides of the box are visible: the left side, the back and the floor.

By default, the three axes decorated with ticks and numbers are X1, Y1 and Z1. By setting the Enabled axes option to Custom, it is possible to specify which axes should be decorated, using the X, Y and Z drop lists that are enabled in this case.

The perspective view mode can be disabled/enabled by checking the Orthogonal box.

Grids Tab

If the coordinate system is visible, you can enable the display of a grid for each of its six sides, by checking the corresponding boxes. The color, pen style and line width of both major and minor grid lines for each of the three axes X, Y or Z, can be customised using the Grid tab

Figure 5-182. The general 3D plot grids tab.

Planes Tab

Using the Planes tab, it is possible to set a color filling for the six sides of the coordinate system. Please note that transparency of these planes is not correctly handled when exporting 3D plots to vectorial image formats (*.EPS, *PDF or *.SVG files). It is also possible to set a Border for the sides of the coordinate system. The color, pen style and line width of the border can be fully customised.

Figure 5-183. The general 3D plot planes tab.

Lighting Tab

Using the Lighting tab it is possible to add a lighting effect to a 3D plot by checking the Enable box. The sliders in this tab allow a quick customization of the various components of the light: the ambient, diffuse and specular colors, the shininess and emission intensity, as well as the direction of the light source.

Figure 5-184. The general 3D plot lighting tab.

The Direction of the light can be controlled with the Horizontal and Vertical sliders, which set the direction for the light source in the horizontal and vertical plane, respectively. The default value for the horizontal slider is 0 degrees, the possible values ranging from 0 to 360 degrees. The values for the vertical direction of the light source range from -180 to 180 degrees.

View Tab

The controls int the Zoom (%) group box can be used to define a global magnification for the 3D plot, as well as the aspect ratio for the three axes of the plot.

The controls int the Rotation group box can be used to in order to set a custom rotation angle around any of the three axes X, Y or Z. When pressing any of the push buttons from the Projection group box, QtiPlot automatically sets rotation angles that enable a view of the XY, XZ or YZ planes. The View XY button, for example, displays a view from the top.

The controls from the Shift group box can be used to define the position of the plot with respect to the margins of the window frame.

Figure 5-185. The general 3D plot view tab.

Stack Tab

The Stack tab is available when the plot contains only 3D curves created from tables. If the plot also contains surfaces, this tab is no longer visible.

Figure 5-186. The general 3D plot stack tab.

The following stacking modes are available:

None:

Curves are not stacked. This is the default mode.

Cumulative:

Z values of 3D curves are stacked cumulatively. If the Normalize to Percent box is checked, the Z axis displays percent values and the stack of curves sums to 100%.

Scale Tab

The scale tab is used to modify the X, Y, and Z ranges. It also allows specification of the number of labels (major ticks) to be drawn on the axes, as well as the number of minor ticks and the first major tick.

Figure 5-187. The surface plot options dialog box.

Axis Title Tab

This tab can be used to define the titles of the three axes and their font. It is possible to enable/disable the display of the title by checking/unchecking the Show box.

The push buttons bellow the text input box allow for easy insertion of subscripts, superscripts, greek characters, special symbols, etc... in your text. The syntax for the formatting of the text is identical to that described for texts in 2D plots, see the detailed explanations in the Text options dialog.

Axis Tab

The controls from the Format group box on the left side of this tab allow to customise the main parameters of the three axes: their width and color, the type and length of the ticks. Tick length is defined in the same units as the axis range. If the graph scales are changed, QtiPlot will re-calculate the length of the ticks.

The controls from the Show Labels group box on the right side of this tab allow to enable/disable the display of the major tick labels and to customise their main properties: font, color, numeric format, distance to axis (gap), etc... It is also possible to define a prefix and suffix for all tick labels.

In the case of the Y axis, there is an additional control available, the Display list box. It allows to select how the tick labels for the Y axis are handled by QtiPlot if the plot contains XYY curves. There are five options available:

Values

The labels display the numerical values.

Column name

The labels display the column name of the Y source data sets.

Column comment

The labels display the comments of the Y source columns.

Column long name

The labels display the long name of the Y source columns.

Full dataset name

The labels display the full name (TableName_ColName) of the Y source columns.

Grid Tab

This tab is used to customise the color, pen style and line width of both major and minor grid lines for each of the three axes X, Y or Z.

Text Tab

This tab is used to define or modify a text in the 3D plot.

The push buttons bellow the text input box allow for easy insertion of subscripts, superscripts, greek characters, special symbols, etc... in your text. The syntax for the formatting of the text is identical to that described for texts in 2D plots, see the detailed explanations in the Text options dialog.

Position Tab

This tab can be used in order to define the position of a 3D text object, using pixel coordinates.

Legend Tab

Each text or color scale can be attached to a 3D legend object. This tab can be used in order to set the parent legend or to detach the text/color scale from a legend object, if the Attach to option is set to None.

Color Scale Tab

The Color Scale tab is used to customize the appearance (color filling and border) of a 3D color scale object.

The color filling can be enabled/disabled using the Fill with Color check box. If enabled, the filling can be Horizontal (the lowest color index is on left side) or Vertical (the lowest color index is on the bottom).

Each color scale can be attached to a 3D surface or can have its own color map. If the Attach to option is set to None, a new Color Map tab is displayed allowing to customize the internal color map of the scale. By pressing the Fill with Color button, QtiPlot opens this tab or, if the color scale is attached to a 3D surface, automatically selects this surface in the elements tree on the left side of the dialog and opens the color map tab corresponding to this surface.

Figure 5-188. The 3D color scale tab.

Axis Tab

The controls from the Format group box allow to customise the main parameters of the axis: its position with respect to the color bar, its color and line width, the distance to the color bar, calculated in pixels, using the Stand-off spin box, as well as the display of a backbone line.

The Scale group box can be used in order to specify a step value for the axis division or the number of labels (major ticks) to be drawn on the axis. It also allows specification of the number of minor ticks and the value of the first major tick.

The controls from the Ticks group box allow to customise the length of the ticks. Tick length is defined in the same units as the axis range. If the graph scales are changed, QtiPlot will re-calculate the length of the ticks.

The Numbers group box, on the right side of the tab, allows to enable/disable the display of the major tick labels and to customize their main properties: font, color and numeric format.

Figure 5-189. The 3D color scale axis tab.

Title Tab

The Title tab can be used in order to customize the title of a 3D color scale.

The push buttons bellow the text input box allow for easy insertion of subscripts, superscripts, greek characters, special symbols, etc... in your text. The syntax for the formatting of the text is identical to that described for texts in 2D plots, see the detailed explanations in the Text options dialog.

Figure 5-190. The 3D color scale title tab.

Geometry Tab

The Geometry tab is used to define the Position and Size of the color bar of a 3D color scale object, using pixel coordinates.

Figure 5-191. The 3D color scale geometry tab.

Legend Tab

Each color scale can be attached to a 3D legend object. This tab can be used in order to set the parent legend or to detach the color scale from a legend, if the Attach to option is set to None.

Figure 5-192. The 3D legend tab.

Group Edit Tab

The Group Edit tab is used to enable/disable the display of a plot legend and its appearance.

Figure 5-193. The 3D legend tab.

Format Tab

The Format tab allows modification of the properties of the 3D curve/surface, like the color and linewidth of the mesh or the style of the data symbols.

The Resolution option is more or less akin to a speed drawing mode, which can be very useful when working with large data sets. Larger values of the Resolution option result in fewer data points being drawn on 3D plots, and therefore a higher drawing speed. When Resolution is set to 1, all data points are drawn.

Format options for 3D surfaces.

Format options for 3D ribbons.

Format options for 3D bars.

Format options for 3D line and symbol curves.

Colors Tab

The Colors tab allows modification of the colors used for the 3D surfaces or symbols. The 3D curves/surfaces internally use a linear color map in order to define the color scheme which is used to show Z-values.

If the Scale Colors box is checked, a Z value will be represented by a color defined as a linear interpolation between the adjacent values in the color table.

It is possible to load or store a colormap from/to a XML file by pressing the Open file and Save buttons.

A click on the Level column header opens the Set Equidistant Levels dialog, which allows to quickly edit the color map levels by specifying their total number and an intensity range.

A click on the Color column header opens the Gradient Fill dialog, which allows to quickly customize the colors in the map.

The Opacity slider can be used in order to modify the alpha channel of the color map from 0 % (totally transparent) to 100 % (fully opaque). The opacity can be set for the Selected Curve only, or for all curves in the Window or for all curves from All Windows, depending on the setting activated in the Apply to select box.

Projection Tab

The Projection tab is only available for 3D surfaces and ribbon plots and can be used in order to customise the aspect of the floor projection.

By default, the floor projection of a 3D surface is disabled. One can enable a full 2D projection or only display the isolines. The number of projected isolines can be customised using the input spin box.

The default floor plane is the Z plane that contains the minimum data vertex of each surface or ribbon. It is possible to change this setting to either the zero plane, the Z plane that contains the maximum data vertex or a custom Z value.

Labels Tab

The Labels tab is used if you want labels displayed near each data point in a 3D curve. Options are provided to control the font, color, rotation angle and position of these labels.

If the Custom option is selected in the Label Form list box, the user can define a custom format in the Format String text input box that shows up. The format string may contain the following synthax specifiers: $(x), $(y) and $(z), as substitutes for the abscissa, ordinate and height values of the curve data points. The display of the numeric values can be customised using the following format specifiers:

*n

Display n significant digits: $(y, *3), where y equals 1.1415, displays 1.14.

.n

Display n decimal places: $(y, .3), where y equals 1.1415, displays 1.141.

E.n

Display n decimal places in engineering format: $(y, E.3), where y equals 0.1415, displays 141.500m.

S.n

Display n decimal places in upper case scientific format: $(y, S.3), where y equals 0.1415, displays 1.415E-01.

If no custom format specifiers are found, QtiPlot uses the values provided in the Format and Precision controls as default, in order to display numeric values in custom labels.

Drop Lines Tab

The Drop Lines tab allows to enable the display of vertical lines, parallel to the Z axis, from each data point of a 3D curve, by checking the Show box. This tab is only visible in the case of 3D curves having the plot style set to Line + Symbols or Ribbon. For 3D surfaces this tab is not visible. The controls in the Show group box can be used in order to customize the color, style and linewidth of the drop lines.

Geometry Tab

In the case of 3D curves having the plot style set to Ribbon, this tab can be used in order to customize the width of the ribbon. The width is calculated in percentages of the Y axis length.

Geometry options for 3D ribbons.

In the case of 3D curves having the plot style set to Bars, this tab can be used in order to customize the shape of the bars. If the Square box is checked, QtiPlot tries to keep the same size for the bars allong X and Y axes, otherwise it is possible to specify different dimensions, using the Width X and Width Y sliders. The Width Top slider can be used in order to define the size of the top plane of the bars with respect to the base plane.

Geometry options for 3D bars.

Normals Tab

In three dimensions, a surface normal, or simply normal, to a surface at point P is a vector perpendicular to the tangent plane of the surface at P. The Normals tab is only available for 3D surfaces created from matrices or mathematical functions. It can be used in order to enable/disable the display of the 3D normal vectors and to customise their appearance.

Offset Tab

The Offset tab is only visible in the case of 3D curves having the plot style set to Line + Symbols or Bars. It allows to add an offset allong X and Y axes for each data point symbol.

Figure 5-194. The 3D bars/symbols offset tab.

Vector Tab

The Vector tab is used to enable/disable the display of 3D vectors and to customise their appearance.

Figure 5-195. The 3D Vector options tab.