Image Options

This dialog allows modification of images which have been created with the Add Image (Alt-I) command from the Graph Menu. The dialog can be opened by double clicking on an image or by right clicking a selected image and then choosing Properties... from the resulting pop-up menu. It can also be embedded into the Plot details dialog when you select an image from the list of objects in a 2D plot layer.

Image Tab

This tab allows changing the file that is displayed by the image object. The file path can be edited manually or can be selected from a file dialog that pops-up when pressing the browsing push button on the right side of the File edit box.

Figure 5-29. The Image Options Dialog: Image Tab

The image data is saved inside the QtiPlot project if the option Save internally is enabled. Otherwise, only a link to the external image file is saved, which is not portable and should be avoided if you intend to send the project file to someone else.

If the Interpolation option is enabled, the image displayed on screen is rendered using bilinear filtering when the image object is resized. As a result the displayed image is much smoother, but this comes with a price: the rendering speed can become low, especially for large images.

Frame Tab

This tab is used to define the shape, color, line style and thickness for the frame of an image object. By default, an image has no frame at all, the Shape being set to None.

Figure 5-30. The Image Options Dialog: Frame Tab

The changes can be applied to the selected image, to all images in the plot layer, to all images in the active window or to all image objects from all plot windows, depending on the selection in the Apply to... box.

It is also possible to define the current frame options as a default style for the frame of all future images by pressing the Set As Default button.

Geometry Tab

The Geometry tab is used to specify the size and the position of the selected image. The coordinates can be set as a function of the scale values displayed on the left (Y) and bottom (X) axes, or in pixels, by choosing the desired method from the Unit pull-down list. Pixel coordinates are relative to the top-left corner of the layer which contains the image.

Figure 5-31. The Image Options Dialog: Geometry Tab